Ability to hide workflows included in a UiPath Library


We are using UiPath libraries extensively in our projects. It is the easiest way for us to share common functionality between our projects.

We are also taking a highly modularised approach to our automations. The aim is to reduce as much as possible the amount of copy and paste code in our workflows.

An unfortunate side effect of this is that when a library is used, the activity selector becomes cluttered with many activities that are not mean to be used outside the library itself. I’ve attached a screen capture of an example of what I mean.

The ability to mark a workflow as ‘hidden’ would be greatly appreciated. This would mean that it would remain available to other workflows within the library, but would not appear in the activity picker.

When working within a library project, you have a “right click / mark private” option on a workflow file.

Can you let us know if this answers your question?


Hi @bogdanripa,

You’re right, the ability to “mark private” a XAML file was exactly what we were looking for. I’m not sure how we missed that option. For those that may stumble across this post, the functionality is mentioned here.

One other cool thing that we’ve noticed is that if you hide, at the file system level, a folder or xaml file, it also will not display in the activity selector. This will make it easy to hide the ‘TestFramework’ folder for example which we use as part of our approach to automated tests.

Thanks for the support, and apologies for not seeing the option before posting.



Has this feature been removed now. I am trying to make a xaml file private in a library so that when i publish i dont see the private ones as activities. Snapshot attached

kindly help

Not sure from which version onwards, but in 2020.10 this feature has now been relegated to the “Ignore from Publish” option when you right click a folder in the Project Panel (this is not exactly self evident in the documentation).

This function in a library allows the workflow to be called by other Library Activities, but just won’t show it in the Library panel when published.

This same function in a project does has it’s namesake function, and doesn’t publish the code from that workflow.

Hope this helps.

Ignore from publish is not the same as mark as private, I’m seeing an error ‘Private file “Invoked Workflow.xaml” is used by activity “Main Workflow.xaml”.’

How do we hide a workflow from the library but still include in the package?