A "wonderful" day after the latest Studio update... (Document Understanding Template)

Guys, this starts to be more sad than funny.
So a month ago I created a new project from template for DocumentUnderstanding (from Studio- Templates).
Everything was working nicely, I did some demonstration for my colleagues etc.
I will do another demo in few days so I just thought I will run the workflow again, you know, just to be sure.

Meanwhile Studio updated to 2022.10.

I opened the process and run.

Error no. 1

Uff, what is that?

To run this application, you must install .NET

(The Yes button does nothing) :face_vomiting:

So I decided (after reading few threads) to go on downloading .NET Desktop 6.0 from here:
Download .NET 6.0 Desktop Runtime (v6.0.10) - Windows x64 Installer

Seems like it works.

Error no. 2


Error waiting for OutOfProcessUi host service. Timeout 30000.

Aha… so let me try to upgrade all the packages to their latest versions.

My UI Automation package was 22.4, now it seems that all is up to date:

 "dependencies": {
    "UiPath.DocumentUnderstanding.ML.Activities": "[1.17.0]",
    "UiPath.Excel.Activities": "[2.16.0]",
    "UiPath.IntelligentOCR.Activities": "[6.5.0]",
    "UiPath.System.Activities": "[22.10.1]",
    "UiPath.UIAutomation.Activities": "[22.10.2]"

Running it, fingers crossed…

Oho! New error…

Error no. 3

Compiler error(s) encountered processing expression "TypeOf(in_Exception) Is BusinessRuleException OrElse
TypeOf(in_Exception) Is DocumentRejectedByUserException".(3) : error BC30002: Type 'DocumentRejectedByUserException' is not defined.	

Okay, seems like I am the first one with this error, lets burn more time and investigate.
Aha, it is in SetTransactionStatus.xaml, let’s open the file.
(One would expect that for example double click on the error will open the respective file where the problem is and maybe even point at the problematic activity, but sadly, no luck this time, maybe in some future…)

So - where is the error? no error mark at any activity - Oh good good!

After playing hide n seek for a while, I found it in the second Flow Decision

Rebooting my PC did not help.
Any ideas? This is kinda urgent.

EDIT: I managed to make it work by deleting this:

 OrElse TypeOf(in_Exception) Is DocumentRejectedByUserException

from the problematic Flow Decision.
However - I guess that is not the correct systematic solution. :crying_cat_face:

Hi @Roman_hruska ,

Are you sure all the Packages/dependencies are in their latest Stable version ?

I did get this error as well when updated the packages to the latest preview versions, but when I degraded them back to the Latest Stable Version it resolved the error.

In my case, the Stable Versions (Studio Not updated to latest version maybe a possibility for difference in stable versions) are below :

Let us know if you find this useful.

Hi supermanPunch

thank you for your time,
All versions are stable.
Actually - degrading this package from 6.5.0 to 6.0.1 solved it.

Still I don’t know what to think about it.

1 Like

@Roman_hruska ,

It seems the newly introduced exception type is removed in the next/latest releases of the IntelligentOCR package.

We might get an Updated DU Framework template soon too (not sure when exactly) which might involve some updations :slightly_smiling_face:

1 Like

So the story continues…

Framework/50_Extract.xaml: This version of the DocumentUnderstanding.ML package is incompatible with UiPath.PDF.Activities older than v3.10.0 and UiPath.IntelligentOCR.Activities older than v6.5.0. Please update the conflicting packages.

:bangbang: :cry:

Hi @Roman_hruska,

Studio 22.10 needs DU Process 22.10.1 for it to work. The DocumentRejectedByUserException was a change made in the IOCR package which is fixed in our latest 22.10.1 version. It was a breaking change, and if you do migrations, you will have to add a new namespace UiPath.IntelligentOCR.Exceptions in the SetTransactionStatus workflow.

Regarding the 2nd Workflow validation error, that is a bug that is being actively worked on. It doesn’t impact the runtime of the workflow, so if you can disable the rule, you can publish it without issues. If you cannot because of governance issues, then you will have to remain on 22.4 for a bit longer until we fix it and release a patch.


Thank you very much!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.