A specified logon session does not exist

Hi Robin,

The patch was released yesterday. Here are the release notes:
https://www.uipath.com/release-notes/uipath-v2018.1.3

Hi Ovi, thanks for the response… i will check it out!
Cheers!

I did not install the new patch, but it worked after I removed KB4088879. This is not one of the updates listed in the release notes for the new version of UiPath.

1 Like

I see this patch has been replaced with KB4088889. Does this new patch resolve the issue? My org is not yet running UiPath 2018, and we have been having issues uninstalling the bad MS patch, wondering if this new one alleviates the issue.

@kborg, I learned today that they also released an update to 2017.1
you could also try updating to that.
https://www.uipath.com/release-notes/uipath-v2017.1.6656

3 Likes

Thanks @ClaytonM, missed that as well.
@ovi - do you have any news on 2016.2? (ancient, I know, but according to versioning it’s still the current LTS).

1 Like

Thanks so much! Where can I download the update from?

Does this required an update to orchestrator and robot?

Hey Andrzej,

Yes, 2016.2 is still LTS, that’s why yesterday was a release containing bug fixes:
https://www.uipath.com/release-notes/uipath-v2016.2.6655

1 Like

Awesome, thank you :slight_smile:
So now 2016.2, 2017.1 and 2018.1 can all be used safely. Sweet :slight_smile:

1 Like

How to download not the latest 2018.1 version, but 2017.1 for example?

Hi Dmitry,

If you subscribe to the release notes(UiPath Release Notes) you will get an email with the announcement and instructions to download.

If you didn’t receive the email, please make a request here: Contact Technical Support and ask for the 2017.1 version you need. Please note to use your company email when making the request.

Thanks,
Viorela

1 Like
Deleted

I’ve updated to 2018.1.4 but I’m still getting the error since last friday. Processes ran smoothly when the windows update was removed, but they were reinstalled and the robot wont run anymore(Gives the logon session error). What else can I do than update to latest UiPath? Windows security updates are important for client.

EDIT: Oh, looks like UiPath installation folder and folder structure changed. Updated the folder path to all processes and should work now. Maybe.

Still having the same problem. Both Orchestrator and Robot machines are upgraded to version 2018.1.4, session timeout = 120s but still getting the same error.
It seems that the RDP session is not being created.

Are there known setting that could interfere (registry / group policy) with the session being created?


Windows Server 2012 R2

Process: mytestproject
Environment: MyEnv
Robot: Test on MyServer
Info: “Executor start process failed, reason System.Runtime.InteropServices.COMException (0x80070520): A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, SettingsDictionary execSettings, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass15_1.<b__0>d.MoveNext()”
Start Time: 2018/04/23 15:19:01
End Time: 2018/04/23 15:21:05

Just found out (after searching for weeks) that the legal caption notice was the culprit why my robot’s could not logon to my machines from the orchestrator. Because i couldn’t change the group policy on short notice i created a scheduled task to import the .reg file every 5 minutes (so at a group policy refresh it will be removed by the script again).

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
“legalnoticecaption”=-
“legalnoticetext”=-

2 Likes

I’m just curious. Did this only start happening after the upgrade to 2018? And by legal notice do you mean the “Attention Network Users” caption when you first RDP into the server or is this something else? We haven’t upgraded yet but about to, so I’m wondering if this might be an issue for us as well.

Hi ClaytonM, No we had the same problem with the 2016 version, 2017 version and 2018 version of UiPath.
The Legal Notice Caption is i’m refering to is like this example (not ours):
image_2032AF6D

1 Like

These values are blank for me what can I do ?

'The resource is in use" indicates another session is logged into the machine. Be sure there are no other sessions logged into this machine.

Hi all,

Am also getting the above issues, any resolution for this would be greatly appreciated.

image

Hi All,

Just wanted to know , do we have a fix in any of the new releases of UiPath for the patch KB4088879.
We have currently uninstalled this patch as we were facing issues with the RDP.