A robot with user name 'someName' is not defined in Orchestrator

Thank you

What is the Error you are getting?

I had the same issue and this was due to the fact that I was using Microsoft account to login to the workstation where the robot was running, to check the adequate name run the command “whoami” in the command prompt and you will see the account you need to use in Orchestrator:

I hope this helps for people using Microsoft’s account to authenticate in their workstations.


We have two different approach to resolve this issue

Option 1. As suggested by other individuals you can change the user details in the uipath orchestrator as per credential standards

Option 2 : Disconnect the the Uipath Studio or UiPath Robot from uipath Orchestrator from system tray ( this will help you to resolve your issue - if you are executing the workflow from uipath studio or uipath robot)

I have disconnected the UiPath orchestrator while executing the uipath workflow from my local machine and now i am able to run the workflow successfully


@Iyce_Winsoft Can i know where did you find assignments to practice?


Try to disable the UiPath.Service.Host and uiPath.Agent from the task manager. make sure the machine name is correct. another work around is to create new provision to refresh orchestrator.

Let us know if you still encounter the issue.




I gave up using Windows 10. Now i am using windows 7 now its working fine anyway thanks for advice.

I’m using win 10 with no issues. glad to help.


How to disconnected ? because i haven’t connected to Orchestrator but it is still throwing this error


Thank u it worked :slight_smile:


Facing problem in Orchestrator CE. While adding robot its showing error that license does not allows this. Before this I have not linked any project to orchestrator or used any robot. its showing zero robots in licence tray.!

Please guide in this!


is the second screen that of Robot Provisioning Screen? I am giving Domain/Username as as you mentioned while creating robot but no help



@hasanarsh, please try adding new Machine using the Standard Machine and use the new generated Machine Key.

Yup that worked but no luck so far with floating one.
Many Thanks buddy

It is not possible installing the UiPath Community Edition for “All Windows User”. We need to install UiPath Community Edition one by one for each Windows user needed. Only the Enterprise edition has the ability to install for all users.

This might be a hint that the Community Edition Robot won’t work with floating robot.

1 Like

am not able to correct it can you please help . am not connected to orchestrator ,just run workflow .it showing like …a robot with user name “some” is not defined in orchestrator

Thank You it was really helpful.

This trick worked for me.

1 Like

Thanks Hector - this was very helpful!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.