404 File Not found Exception / Publishing project is failed error: file not found - Troubleshoot

orchestrator

#1

Description

While publish the project , error - 404 File Not found Exception.

Troubleshooting steps

Usually for a size issue we get 400 Bad response.

Approach 1# :

Reason : If Size of upload package is the issue i.e. >30 MB

Steps to increase the size limit:

  • The server where Orchestrator is hosted -> Go to Start Menu -> Run -> Type in “Inetmgr” to open the IIS settings.
  • Expand sites -> Select “UiPath Orchestrator”.
  • Double-click on “Request Filtering” as shown in the screenshot below.

  • Select “Rules”.

  • Click “Edit Feature Settings”.

  • In the dialogue window that opens you can see the “Maximum allowed content length” field. It is set to 30 million bytes by default, which allows you to upload files up to almost 30MB. Let’s say we want our files to be up to 1GB, then we would need to put “1073741824” there (this number equals 1GB exactly).

  • Also make sure that the “Allow double escaping” option is enabled. It must be enabled for correct downloading of files which names contain a space character.
  • Click OK. Restart IIS once.

Approach 2# :

Reason : Wrong deployment URL mentioned in the Orchestrator UI.

Solution:
Check the Deployment URL in Orchestartor UI .
Possibility of Improper URL provided.
Remove the API and URL and restarted the IIS and tried publishing.
Should be able to publish using UI and Studio
.