2019.6 Start Jobs API

Hi, I just wanted to start a job via API using my new account. It seems like they don’t have anything about Starting a Job in the new updated documentation (Consuming Cloud API Documentation) yet, or I can’t seem to find any.

Tried to access the old StartJob API but to no avail, following response I got:

Using the bearer token I got from:

Any help would be appreciated.

Thanks & Regards,

1 Like

Hi @UiP_Mc,

The URL needs these two parameters also …

https://platform.uipath.com/[account_logical_name]/[service_instance_logical_name] … I mean account logical name and service instance… as per the documentation.

Can you check this?


Hi @HareeshMR, I’ve already tried this and it responded with the same message.

Hi, it worked by adding another header:
The value supplied is from [service_instance_logical_name] https://platform.uipath.com/cloudrpa/api/account/[account_logical_name]/getAllServiceInstances

1 Like


You need to request this to get the logical name: https://platform.uipath.com/cloudrpa/api/getAccountsForUser

I hope you are missing some steps…

Here are the steps you need to do:

  1. Run the javascript code in the browser, which will give you the Code challenge and Code verifier

  2. Modify the account.uipath.com URL with Code challenge and send a request in the Browser itself. Which will ask you to authenticate with the credentials.
    @@@Important steps is that, you need to pass this URL in browser itself and the browser URL will give you the authorization code

  3. Then you need to send request to https://account.uipath.com/oauth/token with body as in the documentation

  4. There you will get the bearer token.

  5. You need to get the logical name, so again a request for : https://platform.uipath.com/cloudrpa/api/getAccountsForUser
    You will get the name.

  6. with all these, try to send the request again


So, you are missing tenant name in the request @UiP_Mc?

Yup. Right after that it worked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.