2019.10 LTS: Orchestrator - strange error

Hi Everyone,

Ever since I can remember - we have been able to update/upgrade Orchestrator with no additional configuration or tweaking. However, since upgrading to the LTS release, we now encounter a really strange error in IIS (Error 500), the detailed summary is as follows:

"This request has been blocked because sensitive information could be disclosed to third party web sites when this is used in a GET request. To allow GET requests, set JsonRequestBehavior to AllowGet."

Exception thrown by:
Abp.Web.Mvc.Controllers.Results.AbpJsonResult.ExecuteResult(ControllerContext context)

I can’t seem to resolve this any further. I have checked the database connection string, pipeline mode, authentication, SSL certificate etc… and all are fine.

Has anyone encountered this and perhaps been able to rectify the error?

Thanks.

Kind regards
Eric

1 Like

@Eric_Scott_Herman I’ve never seen that particular error before but I would love to help recreate it on my end just for the sake of learning how to fix it. Have you considered/ are you using an Orchestrator HTTP Request or just a regular HTTP request for your activity?

Edit: the Orchestrator HTTP request should authenticate automatically as long as you are trying to reach the Orchestrator that you are using to consume a license. Unless you are trying to reach a different Orchestrator I would definitely recommend it.

Also, welcome to the community!

From the exception Message i would derive a relationship to API calls and the mvc App implementing These. So May you can search in this Level for settings e.g Application settings or IIS. But ITS Just an idea

1 Like

Hi Mr_Meeseeks

Thanks for the response and the welcome.

About the error…I assume when you say “request” you are referring to the API. Unfortunately we haven’t even managed to get that far yet.

The error is generated before even arriving at the Orchestrator login page!!

Kind regards
Eric

I am also facing the same issue. But after I reset the IIS it works and after sometime same issue occurs. If some resolved this issue please let me know. This issue start happening after we update 2019.4 version to 2019.10

I also have the same problem with cCrome. For now my workaround is to use Edge browser which seems to be working.

Hi Eric,

Are you using Windows Login? If yes is the machine joined to the AD domain and can reach it?

Regards,
Constantin

There may be multiple problems reported on this thread with similar symptoms. We investigated the error initially reported and we know one cause for it which is specific to orchestrator builds 19.10 or higher:
That is if orchestrator is using windows authentication but orchestrator can’t connect to active directory. Issues with connecting to active directory can be caused by:

  • Orchestrator machine is not joined to the domain or the WindowsAuth.Domain config setting is not configured correctly based on the domain users are using to sign in.
  • Connectivity issues to active directory (network etc…) which could explain intermittent behavior.
  • app pool used by orchestrator configured with a local account that doesn’t have network access privileges.

The Chrome specific issue is different and is being investigated.

1 Like

I have the same error. Is there anyone solved this problem?

Have you found a solution for the chrome specific issue?

We have just updated to 2019.10.15 and now we are not able to login using windows authentication in chrome. It works fine in other browsers, so we have a workaround, but it should work in chrome as well.
Url changes to this after clicking windows login: https://‘URL’.com/MixedAuth?state=

Ok so this is weird. After perusing the responses to this thread we performed a fresh install and tried again with both Microsoft Edge and Opera browsers but the problem still persists. I somehow do not think this is a Chrome specific issue. We are also not using AD either and the requisite WindowsAuth.Domain settings are confirmed as correct in the config file. I might be shooting in the dark here and it maybe a co-incidence but we also upgraded the .NET Framework from 4.7.2 to 4.8 prior to moving to the 2019.10 LTS - could there be some compatibility/conflicting issues created as a consequence of this?

Anyways I plan to tinker with the 2019.10.15 update and see if this resolves the issue.