2018.4.4 UI Robot Tray keeps prompting installing packages

Hi there.

The ui robot tray keeps prompting “installing packages” EVERYTIME i click “play” before it actually runs.
This is delaying all my robot activities in production.

Need your advise/help asap.

Thanks!

Hi @Ezzie,

Can you remove the old published package and publish again.

Hi @anil5, i tried republishing as per your advise.
Sadly, it doesn;t work

Hi,

  1. Is the workflow running when you are running from studio.
  2. Did you delete all packages from robot tray first and published again
  3. Can you provide the nuget package to your colleague and tell them to install to see if they are also getting the same error.
  4. Remove the unwanted project dependencies from manage packages.

Hi @anil5

  1. Yes, it was fine in studio. When i publish, it started to install packages again.
  2. No, i updated from previous packages - will try removing first.
  3. Can’t do so because colleagues are running on 2018.2.1.
  4. Will try doing this.

Hello there! Have you found a solution to this? Seems like I’m facing the same problem too, and the installation of packages is longer than the actual workflow implementation. Would be nice to know if it has been solved!

Thanks & Best Regards

I haven’t :frowning:

Given up with this and would like to go back to 2018.3.

Do you know where i can download the software?

Oh no… alrightie noted and sorry to hear that. I also saw this post below, but have yet to try it out yet.

If you’re using Enterprise version and want to go back to 2018.3, I think you’d have to raise a request it from the technical support team.
Otherwise, if you’re using Community Edition, there is no way to roll back unless it has already been installed on your PC previously.

So much hassle just to switch versions :slightly_frowning_face:
WIll try to reach out to the technical team

1 Like

Yeah :confused: do let me know if there is a solution too! Would be really interested to know as well…

Hi All,

I managed to resolve the issue.
I was facing the issue due to the project.json file as it was created by the older version of the UIPath.

What I did was , I first deleted the project.json file and then opened the MAin.xaml from Studio whuch by default created a new project.json file and once this file was created , I published the code and run the job from orchestrator/Robot Tray, and I did nt receive any issue of “installing packages” this time.
Please let me know if it resolves your issue .:slight_smile:

Regards
Gyan

3 Likes

Oh wow I am so going to try this tomorrow.
Will let you know what happens :joy:

1 Like

Hello any one managed to solve this issue …
I upgraded orchestrator to 2021.4 and now the process is taking time in installation of packages