2018.1.2: Centralized Robot Settings in Orchestrator

I believe, we have bug with ‘Centralized Robot Settings’ (configure the logging level) in 2018.1.2. Behavior on Client side (Robot / Studio) seems to be different than expected. When we enable Trace logging, I don’t see any Trace logs. And when we enable Verbose logging, Trace logs are shown but not Verbose logs.


In all cases, logging level shown on client (System Tray → Settings → show Logging level as Information)

1 Like

@badita FYI, in case this is not noticed by product team already.

I noticed the same issue as well. Do we have a fix for this.

Hi, I’ve noticed what appears to be the same issue in Orchestrator 2018.3 (CE). Is it possible that the Orchestrator logging settings simply overwrite the robot (system tray) logging settings every time? This would seem strange as the settings are under “Orchestrator settings” in the system tray which would imply it gets updated in both places. If anyone could please explain what’s going on that would be great. Is this a bug or expected behavior?

I’ve read the articles on logging at robot level as well as logging within the orchestrator (I’ve also completed the online training) but couldn’t find an answer.

Hi guys!

Let me try to explain better the difference between Trace and Verbose levels:

  • Trace: saves all the custom log messages of level Trace
  • Verbose: saves all the custom log messages of level Trace + all the automatic messages regarding each activity execution and co., also as level Trace

You can see more details here: Logging Levels

1 Like